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Product Installation

Red Giant Software Instant HD is a new plug-in designed for After 
Effects-compatible hosts to run on Mac OS X® (10.3 and later) and 
Windows® XP (Home and Pro editions). Instant HD transforms DV video 
into a variety of HD video formats. You can choose from a list of preset 
resolutions to make it easy to integrate DV video into your next High 
Definition production.

Instant HD comes packaged as a complete software installer. You must 
have installed one of the target applications: Adobe After Effects (6.0 
and later), Premiere Pro (1.5 and later), or Apple Final Cut Pro 4.5 (and 
later) before installing Instant HD. The installer will automatically place 
the required components on your hard drive. The installer will guide 
you through the process of installing the plug-in.

The final step in the installation before using Instant HD is entering 
your serial number into the registration dialog. The registration dialog 
will appear the first time you access Instant HD. YOU MUST ENTER A SE-
RIAL NUMBER TO USE Instant HD. You will receive a confirmation email 
after you purchase that contains your serial number.

The serial number for Instant HD appears in the following format:

#### #### #### #### ####

The activation code is a series of 20 numbers. You must enter all num-
bers to complete the activation.

Product support is available to registered customers only. You can reg-
ister with Red Giant Software by clicking the link below.

You can also register with us by opening your web browser and using 
the following URL: www.redgiantsoftware.com/register.html. 

The best way to reach support is through email. You can email your 
support issue to support@redgiantsoftware.com. 

WelcomeWelcome

InstallationInstallation

ActivationActivation

SupportSupport

 www.redgiantsoftware.com/register.html
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The Instant HD Controls

Instant HD is a plug-in product for After Effects-compatible hosts. At its 
heart, Instant HD is a scaling tool. Scaling is the process of changing an 
image from one pixel resolution to another. When scaling from stan-
dard definition (SD) to high definition (HD), the missing pixels must 
be generated in an intelligent way. Instant HD provides a high-quality 
method for converting SD sources to HD within your favorite video 
application.

The plug-in has five basic controls: Output Size, Filter Type, Sharpness, 
Quality settings, and Antialiasing. The plug-ins for After Effects and Pre-
miere Pro work nearly same and share a common set of controls. Final 
Cut Pro limits the way a plug-in can work so a different workflow and 
set of controls is presented in Final Cut Pro. We will explain the differ-
ences between the host application versions in separate sections.

There is one major limitation in the current Instant HD release. The prod-
uct is specifically designed to work with progressive (non-interlaced) 
images. That means that if you are starting with interlaced video such as a 
standard Sony PD150 DVCAM capture, you will need to convert the image 
to progressive in the host application before applying Instant HD.

Before we jump into the Instant HD plug-in controls, we should discuss 
a little about aspect ratios so that you can get the right results. You 
may be wondering why you can’t just fit a DV video into HD.  To con-
vert the video correctly we need to understand the aspect ratio of the 
source and output. If your source video is NTSC DV, then the image will 
have a resolution of 720 x 480 and a pixel aspect ratio of .90. The video 
frame aspect ratio is 3:2. The pixel aspect ratio denotes the ratio of the 
width to the height of each pixel in the image. With NTSC DV, the pixels 
are 90 percent as wide as they are tall, making the pixels not squares 
but rectangles.

Getting 
Started
Getting 
Started

Understanding 
Aspect Ratios
Understanding 
Aspect Ratios
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NTSC DV Frame

Now the DV frame needs to fill the space of an HD frame. You can 
choose between several HD output resolutions. In our case, let’s stick 
with 720p. The following image shows the HD 720p standard frame 
size.

The HD 720p video frame

So if we look at our DV image scaled to fill the HD frame, we can see 
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that the two won’t exactly match.

The NTSC DV frame placed in an HD size frame.

The two images do not match in aspect ratio, so you end up with black 
bars on either side of the image. These are also called pillar bars, and 
are normal for inserting a standard DV image into an HD frame.

Let’s take a quick look at the math involved to see how Instant HD’s de-
fault settings in After Effects—1280 x 720 (1080 x 720) NTSC DV/Wide-
screen— lets you arrive at the right resolution when scaling video from 
NTSC DV to HD 720p. In After Effects, NTSC DV video is interpreted as 
720 pixels wide by 480 pixels high. Now we want to place this video in 
a HD 720p composition that is 1280 pixels wide by 720 pixels tall. The 
best way to make these sizes match is to fit by height, which means 
making the 480 pixels from source stretch to cover 720 pixels in the 
output. Divide 720 by 480 and you get 1.5, so the NTSC DV video needs 
to be scaled by 150% to fit a 720p output composition. If we multiply 
the 720 pixel width of the input video by 1.5, we will get 1080. 

Aha! Now you see the resolution of 1080 x 720 in our example above 
is stretching NTSC DV video to the HEIGHT of the output composition. 
But the two resolutions don’t match—1080 is not wide enough to 
cover 1280 pixels in the 720p standard, and the outside edges are left 
black. Why not scale the video to 1280? You do this to avoid stretching 
the image. Stretching the video to fill 1280 pixels in width would mean 
scaling the width by 177%. Since this is more that the 150% scale used 
to fit the height of the video, the output image would look stretched, 
with circles becoming wide ovals and your actors or talent looking 
about 30 pounds heavier.  You usually don’t want that, but if you do, 
use the Fit to Fill options. 
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This section will explain each of the controls available in Instant HD. 
The Output Size control will be described separately for each applica-
tion because the output differs based on the application’s handling of 
different video formats.

The Instant HD controls in After Effects 7

Output Size. The resolution pop-up lets you quickly choose the output 
resolution for your video. Typically, the resolution will match the size of 
the composition in After Effects or a sequence in Premiere Pro or Final 
Cut Pro. The presets menu has been formatted to reflect the three dif-
ferent parts of the scaling equation: the target output size, the actual 
resolution applied to the source and the source format.  The menu has 
also been broken into 8 distinct sections to make it easier to choose 
the right output resolution.

ControlsControls
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The Output Size preset menu

The Output size menu may seem slightly confusing because there 
are two different numbers that appear in the Preset choice. Let’s use 
the default preset choice as our example— 1280 x 720 (1080 x 720) 
NTSC DV/Widescreen. The first two numbers are 1280 x 720 one of the 
standard output resolutions for HD video. The second two numbers in 
parentheses (1080 x 720 in the default choice) is the correct resolution 
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for converting you DV Video to HD in After Effects and Premiere Pro. 

You may now be wondering why these are different. The first is the 
resolution of your final project, the second is the resolution that rep-
resents the correct resolution if you are scaling from NTSC DV or NTSC 
DV Widescreen source video—as shown in the final part of the menu. 
All the options that start with an HD resolution, we have created the 
preset to allow the input video to fit by height. All of the options that 
start with Fill try to cover the entire output frame with the input. This is 
referred to as Fit to Fill.

Standard Resolutions . The first section of the output size menu con-
tains the standard definition resolutions. If you are using an image that 
is smaller than DV, you can choose one of the presets to fit your output 
size.

The standard definition resolutions for DV, D1 and PAL.

HD 720p. Section 2 of the menu offers choices for converting between 
standard definition and high definition 720p resolutions. If you want 
to scale your input image to match a 720p project and have the height 
match, then choose from these options. 

The 720p options

Fill HD 720p. Section 3 delivers options for filling the entire 720p 
frame with the input video. These are options are referred to as “fit 
to fill”, because the input image will fill the entire frame. If the aspect 
ratios do not match, then top and bottom of the input frames will be 
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cropped out of the picture.

The Fit to Fill 720p options

HDV 1440 x 1080. Section 4 offers fit-by-height 1080p resolutions 
that match the aspect ratio of HDV video. These options are used if you 
intend to create an HDV output in the native format of 1440 x 1080.

The HDV 1080 fit by height output options

HDV Fit to Fill. Section 5 offers all of the same fit to fill options as 
found in the 720p section. Applying this option to non-16:9 material 
will crop the top and bottom of the frame. The widescreen sources (e.g. 
NTSC DV Widescreen) will fill the entire frame with minimal cropping.

The HDV Fit to Fill options

HD 1920 x 1080 . Section 6 offers the fit-by-height options for out-
putting to 1920 x 1080 output compositions. These scale options are 
best suited for material that has some native sharpness such as un-
compressed video. Scaling DV to 1920 x 1080 can reveal artifacts and 
noticeable noise in the original.



Reference

12Red Giant Software Instant HD

HD 1920 x 1080 fit by height options

HD 1920 x 1080 Fit to Fill. Section 7 offers all of the same fit to fill 
options as found in the 720p section. Applying this option to non-16:9 
material will crop the top and bottom of the frame. The widescreen 
sources (e.g. NTSC DV Widescreen) will nearly fill the entire frame.

 

HD 1920 x 1080 Fit to Fill options

2K Film Resolutions. The last section is reserved for scaling from stan-
dard definition sources to 2K film resolution. In many instances this is 
better left to a hardware devices such as a laser recorder but Instant 
HD can create these images in case hardware output is not available. 
All of these resolutions will Fit to Fill the image to the 2K frame size.

The 2K Film Fit to Fill options

Custom Size. In addition, the last item in the Output Size pop-up is 
Custom. This options allows you to enter custom width and height val-
ues in the Custom Size section of the plug-in. The last actual resolution 
will be shown. If you chose the item above—1280 x 720 (1080 x 720) 
NTSC DV/Widescreen—you would see the 1080 value appear in the 
custom width control and the 720 value appear in the custom height. 
The second numbers in the menu item show the actual resolution of 
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the final output.

The Custom Size control also has a Lock Aspect Ratio check box. When 
checked, the width and height will change proportionally. This makes 
it possible to increase or decrease the scale of the image without dis-
torting the original content. This is useful for increasing the zoom on 
an image without distorting the picture.

Filter Type. There are two quality adjustments in Instant HD. The first is 
a pop-up menu which lets you choose from four scaling modes: Draft, 
Quick, Better, and Best. The Draft mode is a bilinear scale similar to a 
low-quality scale in After Effects and is useful for previewing the size of 
the output. Quick mode improves the output and is closer to the final 
result but still renders fairly quickly. The Better and Best modes are very 
similar. Better will work for most videos and provide improved edges 
and image contrast. The Best mode can provide the finest results but 
the Better mode may be more compatible with your processor type.

Sharpness. This control lets you sharpen the output of the video scal-
ing operation. The slider range lets you choose between 0 (no sharp-
ening) and 25 (very sharp). Low values between 2 and 6 are suitable 
for most operations. High values above 10 can lead to oversharpened 
images that have ringing artifacts.

Quality. This slider lets you adjust the sampling used in the Filter 
Type. The slider ranges from 0 to 25. Low values mean fewer samples 
for each output pixel. High values mean more sample points for each 
output pixel. A mid-range value usually is good balance between edge 
smoothness and detail sharpness.

Antialiasing. The final control in Instant HD lets you add smoothing to 
the edges of images. The slider has a range of 0 to 10. Low values will 
provide small amounts of smoothing for jagged edges. High values 
can smooth out small details. We recommend a setting of 1-4 for most 
images.
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Application Options

Instant HD appears under the Red Giant category in the Effects menu. 
The plug-in should be applied after you set-up your composition to 
one of the HD resolutions.  The following is a quick sequence for using 
Instant HD in After Effects. The menu items covered in the reference 
section are from the After Effects version, so please see the earlier Con-
trols section for detailed information.

The following is a step-by-step instruction for applying Instant HD in 
After Effects 7 to scale a DV image to HD. You should have installed the 
Instant HD plug-in before proceeding.

1. 	 Start by loading a progressive NTSC or DV video file into After Ef-
fects by choosing File > Import or double-clicking in the project 
window.

2. 	 Create a composition of the desired frame size. For this example, 
choose Composition > New Composition... and a new composition 
dialog appears.

	 Choose the HD preset from the Preset pop-up. Then change the 
frame rate to reflect your input media. In this case we are using 
23.976 DV media, so we set the frame rate to 23.976. Finally, set the 
duration to match the length of your input source and click ‘OK’.

3. 	 Drop your source footage from the Project window into the HD 
timeline. The source footage will be added to the HD composition 
and centered in the display.

4. 	 With the source layer selected in the Timeline windows, choose 
Effects > Red Giant > Instant HD. The effect controls window will 
appear.

The settings for Instant HD in After Effects

After EffectsAfter Effects

Getting StartedGetting Started
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	 The default setting in the Output size will automatically scale the 
image to the proper size in the 720p comp. Change the other set-
tings to the following:

Filter Type:	 Best

Sharpness:	 3

Quality:		  10

Anti-aliasing:	 2

	 These values represent a good compromise between sharpness 
and speed.

5. 	 Choose RAM Preview in After Effects to see the results. You should 
now have a Comp ready to render at 720p frame size. You could 
alternately choose a 1080 output size from the Output Size pop-up 
and set your comp to 1080p as well.

The Premiere Pro version of Instant HD is nearly identical to the After 
Effects version. The options and menu items are nearly the same. The 
only difference is in the Preset menu. Premiere Pro treats the input size 
for DV standard and widescreen differently than After Effects. To get 
the right results when choosing to fit-by-height you must specify dif-
ferent presets for DV video and DV Widescreen video. 

Part the Premiere Pro Instant HD Output Size options

For each of the Output Size preset options that fit by height, additional 
presets have been added for Widescreen sources to assure that you get 
the correct result.

The following is a step-by -step instruction for applying Instant HD in 
Premiere Pro (1.5 and later) to scale a DV image to HD resolution. You 
should have installed the Instant HD plug-in before proceeding.

1. 	 Start by creating an HD-resolution project. You can use one of 

Premiere ProPremiere Pro

Getting StartedGetting Started
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the HDV presets or create your own. Check with the Premiere Pro 
documentation if you have questions. For our example, we will use 
a custom 720p project with a time base of 23.976 (24p).

2.	 After creating a new Project, you will have a sequence in the Proj-
ect window that matches the Project settings. Import your footage 
by choosing File > Import or double-clicking in the project win-
dow. You can use the Playground_DV_24p.mov movie found in the 
Instant HD package.

3. 	 Drop your source footage from the Project window into the HD 
Timeline. The source footage will be added to the HD composition 
and centered in the display.

4. 	 With the source footage selected in the Timeline, choose Effect > 
Red Giant > Instant HD or you can drag and drop the Instant HD 
effect from the Effects tab.

The Effects tab showing the Instant HD effect

5.	 Highlight the clip and then click the Effect Controls window. The 
default setting in the Output size will automatically scale the im-
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age to the proper size in the 720p comp.

The Instant HD controls in the Premiere Pro Effects Control window

	 Change the other settings to match the following values:

Filter Type: 	 Best

Sharpness: 	 3

Quality: 		  10

Anti-aliasing: 	 2

	 These values represent a good compromise between sharpness 
and speed.

5. 	 Update the timeline by choosing the Render Timeline option. You 
can complete the project by choosing to Export the timeline to a 
file.
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Instant HD for Final Cut Pro uses a different set-up and workflow and 
has a different interface to match. The Instant HD interface has a preset 
pop-up for input size as well as Custom Size controls. 

The Instant HD interface for Final Cut Pro

The Input Size is used to specify the size of the source video. Instant 
HD will use this to scale to fit (by height) to the dimensions of the se-
quence. The Input Size pop-up menu allows you to choose from stan-
dard NTSC DV, NTSC DV Widescreen, PAL DV/D1, NTSC D1, and NTSC 
D1 Widescreen sources. These are the most common source sizes. 

The Instant HD Input Size pop-up menu options

Once the input size is properly specified, Instant HD will scale the input 
video to fit by height to the output sequence size. The workflow for 
this is explained below. The Custom Size check box lets you override 
the Input size menu. When you click the check box, Instant HD uses the 
values in the Input Width, Input Height and Input Aspect Ratio fields.

Final Cut ProFinal Cut Pro
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Fit to Fill. If you want to fill the entire area of the frame with the output 
video, choose the Fit to Fill check box. If the input video is not wide-
screen, then the output will be scaled up and the top and bottom part 
of the frame will be cropped out of the active area. For widescreen 
standard definition sources, the Fit to Fill option will produce the same 
results as the standard scale and is unnecessary.

The other controls in Final Cut Pro are identical to the After Effects ver-
sion. Refer to the Instant HD Controls reference for more information 
on these controls starting on page 8.

Instant HD for Final Cut Pro has a very different workflow from the 
other plug-ins but is just as easy to use. Final Cut Pro does not let a 
plug-in resize or scale a frame to dimensions larger than the original 
video. To compensate for this limitation, you must use a nested se-
quence and a three-step scaling process. The first step is to create an 
output sequence that will match the final output size that you will 
create. We will call this the Source Sequence. The second step is to nest 
this sequence in your master timeline in HD resolution. We call this the 
Master Sequence. The final step is apply the Instant HD plug-in and 
set the Input Size to match the size of your source video. The following 
tutorial will walk you through the process.

1.	 In this tutorial, we are going to conform NTSC DV footage to match 
a DVCPRO HD 720p24 output using Instant HD. Begin by choosing 
the proper Audio/Video Settings for DVCPRO HD 720p24. Choose 
the Final Cut Pro menu > Audio/Video Settings... A dialog will ap-
pear. Choose the DVCPRO HD - 720p24 option from the Sequence 
Preset pop-up menu. Click OK to confirm your choice.

The Audio/Video Settings Dialog

Getting StartedGetting Started
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2.	 Create a new project by choosing File > New Project. This will cre-
ate a new project tab called Untitled and create a new sequence 
called Sequence 1 in the Project window. Save the project now and 
call it “Instant HD 720p Conform.”

3.	 Next, rename Sequence 1 by highlighting the item and then click-
ing on the name. Rename the sequence to “DVCPRO HD 720p 
Source.” This sequence will be source sequence for Instant HD.

4.	 Create a new sequence, File > New > Sequence. This will have the 
same settings as the last sequence. Highlight the item in the proj-
ect and rename it “DVCPRO HD 720p24 Master.”

5. 	 Import a DV clip that matches the 24p frame rate by choosing File 
> Import... You can use the example clip, Playground_DV_24p.mov 
from the download package or installation CD.

6.	 Drag and drop the Playground_DV_24p.mov footage into the 
DVCPRO HD 720p Source sequence. You have now completed the 
setup of the source sequence.

7.	 Open the DVCPRO HD 720p24 Master sequence (if it is not already 
open). Drag and drop the DVCPRO HD 720p Source sequence onto 
the timeline of the Master sequence.

8.	 Drag and drop the DVCPRO HD 720p Source sequence into the 
Viewer. Reveal the Instant HD filter in the Effects tab under Video 
Filters > Red Giant > Instant HD. Drag and drop the Instant HD filter 
onto the image in the Viewer tab.

Instant HD can be found in the Video Filters folder within Final Cut Pro’s Effects browser.
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9.	 Once Instant HD is applied, the image will be scaled in the Canvas 
window to fit the Master sequence size.

10.	 Click the Filters tab in the Viewer window to reveal the Instant HD 
controls.  Change the filter settings to the following values:

Filter type:	 Best

Sharpness:	 3

Quality:		  10

Antialiasing:	 2

11.	 To see the results, choose Render Selection or hit Command-R 
to render the Master sequence. You can also export the video to 
QuickTime to evaluate the scaling outside of Final Cut Pro.  
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